multer
2.5.0 · 22 Oct 2026MIT30.7M / weekRepositoryHomepagenpmAtom feed
Your version
2.5.0 is the newest release of 2.x.
In short
2 breaking2 security1 fixed4 changed1 internal
- breaking
The minimum supported Node version is now 10.16.0
- breaking
🐛 drain stream. fixes regression in node 18, remove old CI, set minimum node version, fix readme badges, add .npmrc
Security
Fixes 2 advisories that affected 1.4.4
- HighMulter vulnerable to Denial of Service from maliciously crafted requestsGHSA-4pg4-qvpc-4q3h · 19 May 2025Fixed in 2.0.0
- HighMulter vulnerable to Denial of Service via memory leaks from unclosed streamsGHSA-44fp-w29j-9vj5 · 19 May 2025Fixed in 2.0.0
11 advisories affect 2.0.0; 2.5.0 fixes them
- Highmulter vulnerable to Denial of Service via a pending asynchronous fileFilter after request teardownGHSA-q7qp-rjg7-q26m · 23 Oct 2026Fixed in 2.5.0
- Highmulter vulnerable to Denial of Service via crafted multipart field namesGHSA-wc9g-mqfw-jrwm · 8 Sep 2026Fixed in 2.3.0
- Highmulter vulnerable to Denial of Service via oversized array index in field namesGHSA-535w-7cp7-47q4 · 8 Sep 2026Fixed in 2.3.0
- HighMulter vulnerable to Denial of Service via deeply nested field namesGHSA-72gw-mp4g-v24j · 17 Jun 2026Fixed in 2.2.0
- HighMulter Vulnerable to Denial of Service via Uncontrolled RecursionGHSA-5528-5vmv-3xc2 · 5 Mar 2026Fixed in 2.1.1
6 more
- HighMulter vulnerable to Denial of Service via incomplete cleanupGHSA-xf7r-hgr6-v32p · 1 Mar 2026Fixed in 2.1.0
- HighMulter vulnerable to Denial of Service via resource exhaustionGHSA-v52c-386h-88mc · 1 Mar 2026Fixed in 2.1.0
- HighMulter vulnerable to Denial of Service via unhandled exception from malformed requestGHSA-fjgf-rc76-4x9p · 17 Jul 2025Fixed in 2.0.2
- HighMulter vulnerable to Denial of Service via unhandled exceptionGHSA-g5hg-p3ph-g8qg · 5 Jun 2025Fixed in 2.0.1
- ModerateMulter vulnerable to Denial of Service via incomplete cleanup of aborted uploadsGHSA-3p4h-7m6x-2hcm · 17 Jun 2026Fixed in 2.2.0
- Lowmulter vulnerable to file size limit bypass via async fileFilter race conditionGHSA-qvfw-j98x-7q72 · 8 Sep 2026Fixed in 2.3.0
Release note
Important
- breaking
The minimum supported Node version is now 10.16.0
- security
- security
What's Changed
- breaking
🐛 drain stream. fixes regression in node 18, remove old CI, set minimum node version, fix readme badges, add .npmrc
Handle two busboy error events
♻️ fully drain stream
🥅 explicitly handle req error
🚨 lint:fix
⬆️ bump mocha