Packages / multer / Security

HighVulnerabilityGHSA-v52c-386h-88mcCVE-2026-2359Published 1 Mar 2026

Multer vulnerable to Denial of Service via resource exhaustion

Your version

Affected releases · multer

  • 2.x2.0.0 – 2.0.2Fixed in 2.1.0
  • 1.x and older0.0.1 – 1.4.4No fix, no longer updated

On 2.x, the newest line:

npm install multer@2.1.0
Every release on a timeline
2.x
  1. Affected

    2.0.0 – 2.0.2

    3 releases

  2. Fixed

    2.1.0 – 2.5.0

    6 releases, latest

1.x
  1. Affected

    1.0.0 – 1.4.4

    17 releases

0.x
  1. Affected

    0.0.1 – 0.1.8

    15 releases

41 stable releases of multer, oldest to newest, one row per major.

What happens

Impact

A vulnerability in Multer versions < 2.1.0 allows an attacker to trigger a Denial of Service (DoS) by dropping connection during file upload, potentially causing resource exhaustion.

Patches

Users should upgrade to 2.1.0

Workarounds

None