Packages / multer / Security

HighVulnerabilityGHSA-fjgf-rc76-4x9pCVE-2025-7338Published 17 Jul 2025

Multer vulnerable to Denial of Service via unhandled exception from malformed request

Your version

Affected releases · multer

  • 2.x2.0.0 – 2.0.1Fixed in 2.0.2
  • 1.x1.4.4No fix on this line yet

On 2.x, the newest line:

npm install multer@2.0.2
Every release on a timeline
2.x
  1. Affected

    2.0.0 – 2.0.1

    2 releases

  2. Fixed

    2.0.2 – 2.5.0

    7 releases, latest

1.x
  1. Not affected

    1.0.0 – 1.4.3

    16 releases

  2. Affected

    1.4.4

    1 release

41 stable releases of multer, oldest to newest, one row per major.

What happens

Impact

A vulnerability in Multer versions >= 1.4.4-lts.1, < 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed request. This request causes an unhandled exception, leading to a crash of the process.

Patches

Users should upgrade to 2.0.2

Workarounds

None