Packages / multer / Security

HighVulnerabilityGHSA-4pg4-qvpc-4q3hCVE-2025-47944Published 19 May 2025

Multer vulnerable to Denial of Service from maliciously crafted requests

Your version

Affected releases · multer

  • 1.x1.4.4No fix on this line yet

1.x has no fix yet; the newest fixed line:

npm install multer@2.0.0
Every release on a timeline
2.x
  1. Not affected

    2.0.0 – 2.5.0

    9 releases, latest

1.x
  1. Not affected

    1.0.0 – 1.4.3

    16 releases

  2. Affected

    1.4.4

    1 release

41 stable releases of multer, oldest to newest, one row per major.

What happens

Impact

A vulnerability in Multer versions >=1.4.4-lts.1 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process.

Patches

Users should upgrade to 2.0.0

Workarounds

None

References