Packages / send / Security

LowVulnerabilityGHSA-xwg4-93c6-3h42CVE-2014-6394Published 24 Oct 2017

Directory Traversal in send

Your version

Affected releases · send

  • 0.8.x0.8.0 – 0.8.3Fixed in 0.8.4
  • 0.7.x and older0.0.1 – 0.7.4No fix, no longer updated

On 0.8.x, the newest line:

npm install send@0.8.4
Every release on a timeline
1.x
  1. Not affected

    1.0.0 – 1.2.1

    4 releases, latest

0.x
  1. Affected

    0.0.1 – 0.8.3

    26 releases

  2. Fixed

    0.8.4 – 0.19.2

    37 releases

67 stable releases of send, oldest to newest, one row per major.

What happens

Versions 0.8.3 and earlier of send are affected by a directory traversal vulnerability. When relying on the root option to restrict file access it may be possible for an application consumer to escape out of the restricted directory and access files in a similarly named directory.

For example, static(_dirname + '/public') would allow access to _dirname + '/public-restricted'.

Recommendation

Update to version 0.8.4 or later.