Packages / validator / Security

ModerateVulnerabilityGHSA-rh6c-q938-3r9qCVE-2013-7452Published 24 Oct 2017

Moderate severity vulnerability that affects validator

Your version

Affected releases · validator

  • 1.x1.0.0Fixed in 1.1.0
  • 0.5.x and older0.1.0 – 0.5.0No fix, no longer updated

On 1.x, the newest line:

npm install validator@1.1.0
Every release on a timeline
13.x
  1. Not affected

    13.0.0 – 13.15.35

    19 releases, latest

1.x
  1. Affected

    1.0.0

    1 release

  2. Fixed

    1.1.0 – 1.5.1

    11 releases

0.x
  1. Affected

    0.1.0 – 0.5.0

    57 releases

215 stable releases of validator, oldest to newest, one row per major.

What happens

The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via a crafted javascript URI.