Packages / validator / Security
ModerateVulnerabilityGHSA-qpjp-7rp2-9c3fCVE-2013-7451Published 24 Oct 2017
Moderate severity vulnerability that affects validator
Your version
Affected releases · validator
- 1.x1.0.0Fixed in 1.1.0
- 0.5.x and older0.1.0 – 0.5.0No fix, no longer updated
On 1.x, the newest line:
npm install validator@1.1.0Every release on a timeline
13.x
Not affected
13.0.0 – 13.15.35
19 releases, latest
1.x
Affected
1.0.0
1 release
Fixed
1.1.0 – 1.5.1
11 releases
0.x
Affected
0.1.0 – 0.5.0
57 releases
What happens
The validator module before 1.1.0 for Node.js allows remote attackers to bypass the XSS filter via a nested tag.