Packages / @adobe/css-tools / Security
ModerateVulnerabilityGHSA-prr3-c3m5-p7q2CVE-2023-48631Published 30 Nov 2023
@adobe/css-tools Improper Input Validation and Inefficient Regular Expression Complexity
Your version
Affected releases · @adobe/css-tools
- 4.x4.0.0 – 4.3.1Fixed in 4.3.2
On 4.x, the newest line:
npm install @adobe/css-tools@4.3.2Every release on a timeline
Affected
4.0.0 – 4.3.1
7 releases
Fixed
4.3.2 – 4.5.0
8 releases, latest
What happens
Impact
@adobe/css-tools version 4.3.1 and earlier are affected by an Improper Input Validation vulnerability that could result in a denial of service while attempting to parse CSS.
Patches
The issue has been resolved in 4.3.2.
Workarounds
None
References
N/A