Packages / forwarded / Security
HighVulnerabilityGHSA-mpcf-4gmh-23w8CVE-2017-16118Published 24 Jul 2018
Regular Expression Denial of Service in forwarded
Your version
Affected releases · forwarded
- 0.1.x0.1.0 – 0.1.1Fixed in 0.1.2
- 0.0.x0.0.0No fix on this line yet
On 0.1.x, the newest line:
npm install forwarded@0.1.2Every release on a timeline
Affected
0.0.0 – 0.1.1
3 releases
Fixed
0.1.2 – 0.2.0
2 releases, latest
What happens
Affected versions of forwarded are vulnerable to regular expression denial of service when parsing specially crafted user input.
Recommendation
Update to version 0.1.2 or later