Packages / systeminformation / Security
ModerateVulnerabilityGHSA-m57p-p67h-mq74CVE-2020-26274Published 16 Dec 2020
Command Injection Vulnerability in systeminformation
Your version
Affected releases · systeminformation
- 4.x4.0.0 – 4.31.0Fixed in 4.31.1
- 3.x and older1.0.0 – 3.54.0No fix, no longer updated
On 4.x, the newest line:
npm install systeminformation@4.31.1Every release on a timeline
5.x
Not affected
5.0.0 – 5.33.18
375 releases, latest
4.x
Affected
4.0.0 – 4.31.0
173 releases
Fixed
4.31.1 – 4.34.23
36 releases
3.x
Affected
3.0.0 – 3.54.0
177 releases
2.x
Affected
2.0.0 – 2.0.5
6 releases
1.x
Affected
1.0.0 – 1.0.7
8 releases
What happens
Impact
command injection vulnerability
Patches
Problem was fixed with a shell string sanitation fix. Please upgrade to version >= 4.31.1
Workarounds
If you cannot upgrade, be sure to check or sanitize service parameter strings that are passed to si.inetLatency()
For more information
If you have any questions or comments about this advisory:
Open an issue in systeminformation