Packages / systeminformation / Security
HighVulnerabilityGHSA-jff2-qjw8-5476CVE-2021-21388Published 6 Apr 2021
Command Injection Vulnerability in systeminformation
Your version
Affected releases · systeminformation
- 5.x5.0.0 – 5.6.3Fixed in 5.6.4
- 4.x and older1.0.0 – 4.34.23No fix, no longer updated
On 5.x, the newest line:
npm install systeminformation@5.6.4Every release on a timeline
5.x
Affected
5.0.0 – 5.6.3
35 releases
Fixed
5.6.4 – 5.33.18
340 releases, latest
4.x
Affected
4.0.0 – 4.34.23
209 releases
3.x
Affected
3.0.0 – 3.54.0
177 releases
2.x
Affected
2.0.0 – 2.0.5
6 releases
1.x
Affected
1.0.0 – 1.0.7
8 releases
What happens
Impact
command injection vulnerability
Patches
Problem was fixed with a parameter check. Please upgrade to version >= 5.6.4
Workarounds
If you cannot upgrade, be sure to check or sanitize service parameters that are passed to si.inetLatency(), si.inetChecksite(), si.services(), si.processLoad() ... do only allow strings, reject any arrays. String sanitation works as expected.