Packages / @sveltejs/adapter-vercel / Security

ModerateVulnerabilityGHSA-9pq4-5hcf-288cCVE-2026-27118Published 19 Feb 2026

Cache poisoning in @sveltejs/adapter-vercel

Your version

Affected releases · @sveltejs/adapter-vercel

  • 6.x6.0.0 – 6.3.1Fixed in 6.3.2
  • 5.x and older0.0.1 – 5.10.3No fix, no longer updated

On 6.x, the newest line:

npm install @sveltejs/adapter-vercel@6.3.2
Every release on a timeline
7.x
  1. Not affected

    7.0.0 – 7.0.1

    2 releases, latest

6.x
  1. Affected

    6.0.0 – 6.3.1

    7 releases

  2. Fixed

    6.3.2 – 6.3.4

    3 releases

5.x
  1. Affected

    5.0.0 – 5.10.3

    36 releases

4.x
  1. Affected

    4.0.0 – 4.0.5

    6 releases

3.x
  1. Affected

    3.0.0 – 3.1.0

    5 releases

2.x
  1. Affected

    2.0.0 – 2.4.3

    16 releases

1.x
  1. Affected

    1.0.0 – 1.0.6

    7 releases

0.x
  1. Affected

    0.0.1 – 0.0.3

    3 releases

85 stable releases of @sveltejs/adapter-vercel, oldest to newest, one row per major.

What happens

Versions of @sveltejs/adapter-vercel prior to 6.3.2 are vulnerable to cache poisoning. An internal query parameter intended for Incremental Static Regeneration (ISR) is accessible on all routes, allowing an attacker to cause sensitive user-specific responses to be cached and served to other users.

Successful exploitation requires a victim to visit an attacker-controlled link while authenticated.

Existing deployments are protected by Vercel's WAF, but users should upgrade as soon as possible.