Packages / systeminformation / Security
HighVulnerabilityGHSA-2m8v-572m-ff2vCVE-2021-21315Published 16 Feb 2021
Command Injection Vulnerability
Your version
Affected releases · systeminformation
- 5.x5.0.0 – 5.3.0Fixed in 5.3.1
- 4.x and older1.0.0 – 4.34.23No fix, no longer updated
On 5.x, the newest line:
npm install systeminformation@5.3.1Every release on a timeline
5.x
Affected
5.0.0 – 5.3.0
24 releases
Fixed
5.3.1 – 5.33.18
351 releases, latest
4.x
Affected
4.0.0 – 4.34.23
209 releases
3.x
Affected
3.0.0 – 3.54.0
177 releases
2.x
Affected
2.0.0 – 2.0.5
6 releases
1.x
Affected
1.0.0 – 1.0.7
8 releases
What happens
Impact
command injection vulnerability
Patches
Problem was fixed with a parameter check. Please upgrade to version >= 5.3.1
Workarounds
If you cannot upgrade, be sure to check or sanitize service parameters that are passed to si.inetLatency(), si.inetChecksite(), si.services(), si.processLoad() ... do only allow strings, reject any arrays. String sanitation works as expected.