Packages / lodash / Security

ModerateVulnerabilityGHSA-xxjr-mmjv-4gpgCVE-2025-13465Published 21 Jan 2026

Lodash has Prototype Pollution Vulnerability in `_.unset` and `_.omit` functions

Your version

Affected releases · lodash

  • 4.x4.0.0 – 4.17.21Fixed in 4.17.23

On 4.x, the newest line:

npm install lodash@4.17.23
Every release on a timeline
  1. Not affected

    0.1.0 – 3.10.1

    57 releases

  2. Affected

    4.0.0 – 4.17.21

    53 releases

  3. Fixed

    4.17.23 – 4.18.1

    3 releases, latest

113 stable releases of lodash, oldest to newest.

What happens

Impact

Lodash versions 4.0.0 through 4.17.22 are vulnerable to prototype pollution in the _.unset and _.omit functions. An attacker can pass crafted paths which cause Lodash to delete methods from global prototypes.

The issue permits deletion of properties but does not allow overwriting their original behavior.

Patches

This issue is patched on 4.17.23.