Packages / @apollo/experimental-nextjs-app-support / Security

HighVulnerabilityGHSA-rv8p-rr2h-fgpgCVE-2024-23841Published 30 Jan 2024

@apollo/experimental-nextjs-app-support Cross-site Scripting vulnerability

Your version

Affected releases · @apollo/experimental-nextjs-app-support

  • 0.6.x and older0.0.1 – 0.6.0No fix, no longer updated

0.6.x has no fix yet; the newest fixed line:

npm install @apollo/experimental-nextjs-app-support@0.7.0
Every release on a timeline
  1. Affected

    0.0.1 – 0.6.0

    20 releases

  2. Fixed

    0.7.0 – 0.14.5

    32 releases, latest

52 stable releases of @apollo/experimental-nextjs-app-support, oldest to newest.

What happens

Impact

The @apollo/experimental-apollo-client-nextjs NPM package is vulnerable to a cross-site scripting vulnerability. This vulnerability arises from improper handling of untrusted input when @apollo/experimental-apollo-client-nextjs performs server-side rendering of HTML pages. To fix this vulnerability, we implemented appropriate escaping to prevent javascript injection into rendered pages.

Patches

To fix this issue, please update to version 0.7.0 or later.

Workarounds

There are no known workarounds for this issue. Please update to version 0.7.0