Packages / lodash / Security

HighVulnerabilityGHSA-p6mc-m468-83gwCVE-2020-8203Published 15 Jul 2020

Prototype Pollution in lodash

Your version

Affected releases · lodash

  • 4.x4.0.0 – 4.17.18Fixed in 4.17.19
  • 3.x3.7.0 – 3.10.1No fix on this line yet

On 4.x, the newest line:

npm install lodash@4.17.19
Every release on a timeline
4.x
  1. Affected

    4.0.0 – 4.17.18

    50 releases

  2. Fixed

    4.17.19 – 4.18.1

    6 releases, latest

3.x
  1. Not affected

    3.0.0 – 3.6.0

    9 releases

  2. Affected

    3.7.0 – 3.10.1

    8 releases

113 stable releases of lodash, oldest to newest, one row per major.

What happens

Versions of lodash prior to 4.17.19 are vulnerable to Prototype Pollution. The functions pick, set, setWith, update, updateWith, and zipObjectDeep allow a malicious user to modify the prototype of Object if the property identifiers are user-supplied. Being affected by this issue requires manipulating objects based on user-provided property values or arrays.

This vulnerability causes the addition or modification of an existing property that will exist on all objects and may lead to Denial of Service or Code Execution under specific circumstances.