Packages / sharp / Security

HighVulnerabilityGHSA-f88m-g3jw-g9cjCVE-2026-114113Published 21 Jul 2026

sharp inherited vulnerabilities in libvips: CVE-2026-33327, CVE-2026-33328, CVE-2026-35590, CVE-2026-35591

Your version

Affected releases · sharp

  • 0.34.x0.34.0 – 0.34.5No fix on this line yet
  • 0.33.x and older0.0.1 – 0.33.5No fix, no longer updated

0.34.x has no fix yet; the newest fixed line:

npm install sharp@0.35.0
Every release on a timeline
  1. Affected

    0.0.1 – 0.34.5

    144 releases

  2. Fixed

    0.35.0 – 0.35.5

    6 releases, latest

150 stable releases of sharp, oldest to newest.

What happens

Impact

A number of vulnerabilities, two rated as "High" severity using CVSSv4, have been discovered and fixed in the upstream libvips dependency.

Those processing untrusted input with versions of sharp prior to 0.35.0 are affected.

Patches

Using prebuilt binaries provided by sharp?

Most people rely on the prebuilt binaries provided by sharp.

Please upgrade sharp to the latest version, currently 0.35.3, which provides libvips 8.18.3.

Using a globally-installed libvips?

Please ensure you are using the latest libvips 8.18.3.

Workarounds

Add the following to your code to prevent sharp from decoding GIF, TIFF and VIPS images.

sharp.block({ operation: ["VipsForeignLoadNsgif", "VipsForeignLoadTiff", "VipsForeignLoadVips"] });