Packages / @sentry/node / Security

ModerateVulnerabilityGHSA-6465-jgvq-jhgpCVE-2025-65944Published 24 Nov 2025

Sentry's sensitive headers are leaked when `sendDefaultPii` is set to `true`

Your version

Affected releases · @sentry/node

  • 10.x10.11.0 – 10.26.0Fixed in 10.27.0

On 10.x, the newest line:

npm install @sentry/node@10.27.0
Every release on a timeline
11.x
  1. Not affected

    11.0.0 – 11.9.0

    10 releases, latest

10.x
  1. Not affected

    10.0.0 – 10.10.0

    11 releases

  2. Affected

    10.11.0 – 10.26.0

    16 releases

  3. Fixed

    10.27.0 – 10.77.1

    58 releases

578 stable releases of @sentry/node, oldest to newest, one row per major.

What happens

Impact

In version 10.11.0, a change to how the SDK collects request data in Node.js applications caused certain incoming HTTP headers to be added as trace span attributes. When sendDefaultPii: true was set, a few headers that were previously redacted - including Authorization and Cookie - were unintentionally allowed through.

Sentry’s server-side scrubbing (handled by Sentry's Relay edge proxy) normally serves as a second layer of protection. However, because it relied on the same matching logic as the SDK, it also failed to catch these headers in this case.

Users may be impacted if:

  1. Their Sentry SDK configuration has sendDefaultPii set to true

  2. Their application uses one of the Node.js Sentry SDKs with version from 10.11.0 to 10.26.0 inclusively:

  • @sentry/astro

  • @sentry/aws-serverless

  • @sentry/bun

  • @sentry/google-cloud-serverless

  • @sentry/nestjs

  • @sentry/nextjs

  • @sentry/node

  • @sentry/node-core

  • @sentry/nuxt

  • @sentry/remix

  • @sentry/solidstart

  • @sentry/sveltekit

Users can check if their project was affected, by visiting Explore → Traces and searching for “http.request.header.authorization”, “http.request.header.cookie” or similar. Any potentially sensitive values will be specific to users' applications and configurations.

Patches

The issue has been patched in all Sentry JavaScript SDKs starting from the 10.27.0 version.

Workarounds

Sentry strongly encourage customers to upgrade the SDK to the latest available version, 10.27.0 or later. If it is not possible, consider setting sendDefaultPii: false to avoid unintentionally sending sensitive headers. See here for documentation.

Resources