---
title: "GHSA-4pg4-qvpc-4q3h: Multer vulnerable to Denial of Service from maliciously crafted requests"
description: "High severity. Multer vulnerable to Denial of Service from maliciously crafted requests. Affects multer; fixed in 2.0.0."
url: https://inlinr.com/advisories/GHSA-4pg4-qvpc-4q3h
lang: en
---

[Packages](https://inlinr.com/packages) / [multer](https://inlinr.com/packages/multer) / [Security](https://inlinr.com/packages/multer/security)

High Vulnerability GHSA-4pg4-qvpc-4q3h CVE-2025-47944 Published 19 May 2025

# Multer vulnerable to Denial of Service from maliciously crafted requests

Your version 

Affected releases · [multer](https://inlinr.com/packages/multer)

- 1.x 1.4.4 No fix on this line yet

1.x has no fix yet; the newest fixed line:

```
npm install multer@2.0.0
```

Every release on a timeline

2.x 

1. Not affected

2.0.0 – 2.5.0  
9 releases, latest

1.x 

1. Not affected

1.0.0 – 1.4.3  
16 releases
2. Affected

1.4.4  
1 release

41 stable releases of multer, oldest to newest, one row per major.

## What happens

Impact

A vulnerability in Multer versions >=1.4.4-lts.1 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process.

Patches

Users should upgrade to `2.0.0`

Workarounds

None

References

- [#1176](https://github.com/expressjs/multer/issues/1176 "https://github.com/expressjs/multer/issues/1176")
- [2c8505f](https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665 "https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665")

## How it is exploited

Exploitable over the network, with no account and no action from a user.

- **Confidentiality**: none
- **Integrity**: none
- **Availability**: high

CVSS:3.1/​AV:N/​AC:L/​PR:N/​UI:N/​S:U/​C:N/​I:N/​A:H

## References

- [Reference](https://github.com/expressjs/multer/security/advisories/GHSA-4pg4-qvpc-4q3h "https://github.com/expressjs/multer/security/advisories/GHSA-4pg4-qvpc-4q3h")  
github.com/expressjs/multer/security/advisories…
- [NVD](https://nvd.nist.gov/vuln/detail/CVE-2025-47944 "https://nvd.nist.gov/vuln/detail/CVE-2025-47944")  
nvd.nist.gov/vuln/detail/CVE-2025-47944
- [Issue](https://github.com/expressjs/multer/issues/1176 "https://github.com/expressjs/multer/issues/1176")  
#1176
- [Fix commit](https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665 "https://github.com/expressjs/multer/commit/2c8505f207d923dd8de13a9f93a4563e59933665")  
2c8505f
- [Package](https://github.com/expressjs/multer "https://github.com/expressjs/multer")  
github.com/expressjs/multer
